RebarShapeTerminationsData Class


Rebar Shape Terminations Data Class

Class that stores data about rebar shape's terminations (e.g. hooks, cranks, end treatments)
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeTerminationsData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class RebarShapeTerminationsData : IDisposable

The RebarShapeTerminationsData type exposes the following members.

Constructors
Name Description
Public method RebarShapeTerminationsData Creates a new instance of RebarShapeTerminationData with the default values.
Top
Properties
Name Description
Public property EndTreatmentTypeIdAtEnd Identifies the end treatement type at the end of the rebar shape. Setting this property to a valid value, will set the HookAngleAtEnd to 0 and HasCrankAtEnd to false.
Public property EndTreatmentTypeIdAtStart Identifies the end treatment type at the start of the rebar shape. Setting this property to a valid value, will set the HookAngleAtStart to 0 and HasCrankAtStart to false.
Public property HasCrankAtEnd Identifies if the rebar shape has crank at end. Setting this property to true, will set the HookAngleAtEnd to 0 and EndTreatmentTypeIdAtEnd to ElementId.InvalidElementId.
Public property HasCrankAtStart Identifies if the rebar shape has crank at start. Setting this property to true, will set the HookAngleAtStart to 0 and EndTreatmentTypeIdAtStart to ElementId.InvalidElementId.
Public property HookAngleAtEnd Identifies the hook angle (in degrees) at the end of the rebar shape. The angle must be at least 0 and no more than 180. In case it is 0 it will be considered that the shape doesn't have a hook. Common values are 0, 90, 135, and 180. Setting this property to a value strictly greater than 0 and less or almost equal with 180 will set the HasCrankAtEnd to false and EndTreatmentTypeIdAtEnd to ElementId.InvalidElementId.
Public property HookAngleAtStart Identifies the hook angle (in degrees) at the start of the rebar shape. The angle must be at least 0 and no more than 180. In case it is 0 it will be considered that the shape doesn't have a hook. Common values are 0, 90, 135, and 180. Setting this property to a value strictly greater than 0 and less or almost equal with 180 will set the HasCrankAtStart to false and EndTreatmentTypeIdAtStart to ElementId.InvalidElementId.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TerminationOrientationAtEnd

Identifies the orientation of the termination (e.g. hook, crank) at end.

The default value is Left.

Public property TerminationOrientationAtStart

Identifies the orientation of the termination (e.g. hook, crank) at start.

The default value is Left.

Public property TerminationRotationAngleAtEnd

Identifies the termination's (e.g. hook, crank) out of plane rotation angle (in radians) at the end of the rebar shape.

The default value is 0.

Public property TerminationRotationAngleAtStart

Identifies the termination's (e.g. hook, crank) out of plane rotation angle (in radians) at the start of the rebar shape.

The default value is 0.

Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarShapeTerminationsData
Public method GetDocument Gets the document containing the end treatment ids.
Top
See Also