GetTerminationOrientation Method


Rebar Container Item Get Termination Orientation Method

Gets the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public RebarTerminationOrientation GetTerminationOrientation(
	int end
)

Parameters

end Int32
0 for the start hook, 1 for the end hook.

Return Value

RebarTerminationOrientation

Returns the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.

Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
See Also