GetCableSize Method


Cable Size Get Cable Size Method

Gets the Cable Size data by given Cable Size id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static CableSize GetCableSize(
	Document document,
	ElementId cableSizeId
)

Parameters

document Document
The document.
cableSizeId ElementId
The Cable Size id.

Return Value

CableSize
The Cable Size data.
Exceptions
Exception Condition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also