CableSize Class


Cable Size Class

This class represents the definition of Cable Size data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical CableSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CableSize : IDisposable

The CableSize type exposes the following members.

Properties
Name Description
Public property Comments The comments of this Cable Size.
Public property GroundConductorSize The size of a Ground Conductor.
Public property HotConductorSize The size of a Hot Conductor.
Public property Id The Cable Size id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of this Cable Size.
Public property NeutralConductorSize The size of a Neutral Conductor.
Public property NumberOfGroundConductors The number of Ground Conductors.
Public property NumberOfHotConductors The number of Hot Conductors.
Public property NumberOfNeutralConductors The number of Neutral Conductors.
Public property NumberOfOtherConductors The number of Other Conductors.
Public property OtherConductorSize The size of an Other Conductor.
Top
Methods
Name Description
Public method Static member Create Creates a Cable Size.
Public method Dispose Releases all resources used by the CableSize
Public method Duplicate Duplicates this Cable Size.
Public method Static member GetCableSize Gets the Cable Size data by given Cable Size id.
Public method Static member GetCableSizeIdByName Gets the Cable Size id by given Cable Size name.
Public method Static member GetCableSizeIds Gets all the Cable Size ids in the given document, sorted by name.
Top
See Also