SetCrankStraightLength Method


Rebar Bar Type Set Crank Straight Length Method

Sets the crank straigh length for the specified Rebar Crank Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankStraightLength(
	ElementId rebarCrankTypeId,
	double crankStraightLength
)

Parameters

rebarCrankTypeId ElementId
The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
crankStraightLength Double
The new value of the crank straight length.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category. -or- For the specified Rebar Crank Type is auto calculated and the cannot be manually set. -or- The crank parameters cannot be computed for the specified crankStraightLength and Rebar Crank Type.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for crankStraightLength must be positive.
Remarks
When the crank straight length is set, the crank ratio is keeping the same value. The offset length and angled length are adjusted.
See Also