IsLoaded Method


Revit Link Type Is Loaded Method

Checks whether the link with this id is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsLoaded(
	Document document,
	ElementId typeId
)

Parameters

document Document
A document. Revit will see if typeId corresponds to a loaded link in this document.
typeId ElementId
An element id. Revit will check if typeId corresponds to a loaded link in the given document.

Return Value

Boolean
True if typeId corresponds to a loaded RevitLinkType. False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Returns false if typeId is not the id of a RevitLinkType.
See Also