IsPhaseCreatedValid Method


Element Is Phase Created Valid Method

Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsPhaseCreatedValid(
	ElementId createdPhaseId
)

Parameters

createdPhaseId ElementId
The id of a Phase.

Return Value

Boolean
True if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Acts as a validator for setting the property CreatedPhaseId.
See Also