GetOverlaps Method


Curve Intersect Result Get Overlaps Method

Gets information about the points shared between the two curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<CurveOverlapPoint> GetOverlaps()

Return Value

IList CurveOverlapPoint
The list of CurveOverLapPoints corresponding to points of intersection and/or intervals of overlap for the two curves.
Exceptions
Exception Condition
InvalidOperationException This CurveIntersectResult only contains simple output. Use CurveIntersectResultOption::Detailed to compute detailed output.
Remarks

A CurveOverlapPoint whose type is CurveOverlapPointType.Intersection indicates an individual point of transverse intersection. An interval of curve overlap is indicated by two consecutive points -- the start point of the interval (having Type CurveOverlapPointType.IntervalStart), immediately followed by the end point of the interval (having Type CurveOverlapPointType.IntervalEnd).

An overlap interval may be degenerate, in which case it indicates that the two curves are arranged end-to-end with shared end points. The Overlaps of a CurveIntersectResult may contain a combination of one or more intersection points and/or overlap intervals.

See Also