CurveIntersectResult Class


Curve Intersect Result Class

Contains the result of intersecting two curves and, if requested, a description of points where the two curves overlap or intersect.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CurveIntersectResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CurveIntersectResult : IDisposable

The CurveIntersectResult type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Result The classification of intersection or overlap between the two curves.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CurveIntersectResult
Public method GetOverlaps Gets information about the points shared between the two curves.
Top
See Also