SubmitPrint Method (View)


Print Manager Submit Print(View) Method

Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SubmitPrint(
	View view
)

Parameters

view View
The User-assigned view.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception Condition
InvalidOperationException Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.
Remarks
PrintManager will apply the local settings to global and print the user-assigned view with the current settings.
See Also