GetAllRebarCrankTypes Method


Rebar Crank Type Utils Get All Rebar Crank Types Method

Gets all the Rebar Crank Types elements from the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static IList<ElementId> GetAllRebarCrankTypes(
	Document document
)

Parameters

document Document
The document.

Return Value

IList ElementId
Returns all the Rebar Crank Types elements from the document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Internally this function is returning all element ids from a FilteredElementCollector of category BuiltInCategory.OST_RebarCrankType.
See Also