IsCoreLayer Method


Compound Structure Is Core Layer Method

Checks if the specified layer is a core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsCoreLayer(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

Boolean
Returns true if the layer is within the core layer boundary, false if it is in the interior or exterior shell layers.
Remarks
You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32) .
See Also