AddWireMaterialType Method


Electrical Setting Add Wire Material Type Method

Note: This API is now obsolete.

Add a new type of wire material.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("AddWireMaterialType is deprecated in Revit 2026 and will be removed in a future version of Revit. Please use ConductorMaterial.Create() instead.")]
public WireMaterialType AddWireMaterialType(
	string name,
	WireMaterialType baseMaterial
)

Parameters

name String
Name of new material type.
baseMaterial WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

WireMaterialType
New added wire material type object.
See Also