DirectContext3DHandleSettings Class


Direct Context 3DHandle Settings Class

Overriding settings applied to DirectContext3DHandles through the Visibility dialog.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D DirectContext3DHandleSettings

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class DirectContext3DHandleSettings : IDisposable

The DirectContext3DHandleSettings type exposes the following members.

Constructors
Name Description
Public method DirectContext3DHandleSettings Constructs an instance of settings with default values.
Public method DirectContext3DHandleSettings(DirectContext3DHandleSettings) Constructs a copy of source object.
Public method DirectContext3DHandleSettings(Boolean, Int32) Constructs an instance of settings with provided values.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Visibility Visibility of the handle and the associated DirectContext3D graphics. A value of true means that the graphics are visible.
Top
Methods
Name Description
Public method Assign Assigns values of the source settings to this object.
Public method Dispose Releases all resources used by the DirectContext3DHandleSettings
Public method GetColor Gets the color of the handle and the associated DirectContext3D graphics.
Public method GetTransparency Gets the transparency value of the handle and the associated DirectContext3D graphics.
Public method IsEqual Check if the contents of two instances of settings are equal.
Public method SetColor Sets the color of the handle and the associated DirectContext3D graphics.
Public method SetTransparency Sets the transparency value of the handle and the associated DirectContext3D graphics.
Public method SetVisibility Visibility of the handle and the associated DirectContext3D graphics. A value of true means that the graphics are visible.
Top
Remarks

DirectContext3D graphics can be displayed with or without an associated DirectContext3D handle element. For DirectContext3D graphics that utilize the handle element, the visibility and appearance of the graphics can be adjusted through the Visibility/Graphics dialog.

See Also