GetConductorSize Method


Conductor Size Get Conductor Size Method

Gets the Conductor Size data by given Conductor Size id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static ConductorSize GetConductorSize(
	Document document,
	ElementId conductorSizeId
)

Parameters

document Document
The document.
conductorSizeId ElementId
The Conductor Size id.

Return Value

ConductorSize
The Conductor Size data.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The id is not a Conductor Size id.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also