ConductorSize Class


Conductor Size Class

This class represents the definition of Conductor Size data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ConductorSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class ConductorSize : IDisposable

The ConductorSize type exposes the following members.

Properties
Name Description
Public property Diameter The diameter of the conductor.
Public property Id The Conductor Size id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The Conductor Size name.
Top
Methods
Name Description
Public method Static member Create Creates a Conductor Size.
Public method Dispose Releases all resources used by the ConductorSize
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Static member GetConductorSize Gets the Conductor Size data by given Conductor Size id.
Public method Static member GetConductorSizeIdByName Gets the Conductor Size id by given Conductor Size name.
Public method Static member GetConductorSizeIds Gets all the Conductor Size ids in the given document, sorted by name.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also