Result Property


Curve Intersect Result Result Property

The classification of intersection or overlap between the two curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public SetComparisonResult Result { get; }

Property Value

SetComparisonResult
Remarks

SetComparisonResult.Overlap - One or more intersections or overlapping intervals were encountered.

SetComparisonResult.Subset - The curve used to invoke the intersection check is a bound curve whose bounded interval is entirely within the curve passed as an argument.

SetComparisonResult.Superset - The bounded input curve is entirely within the curve used to invoke the intersection check.

SetComparisonResult.Disjoint - There is no intersection or overlap found between the two curves.

SetComparisonResult.Equal - The two curves are identical.

See Also