IsExportingPropertySet Method


IFCParameter Template Is Exporting Property Set Method

Determines whether the provided property set is included in export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsExportingPropertySet(
	PropertySetupType propertySetupType,
	string propertySetName
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySetName String
The property set name.

Return Value

Boolean
Whether or not the property set is included in export.
Exceptions
Exception Condition
ArgumentException A property set with the given name is not present in the template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also