GetPropertySetNames Method


IFCParameter Template Get Property Set Names Method

Creates an array of property set names contained in the template according to provided selection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<string> GetPropertySetNames(
	PropertySetupType propertySetupType,
	PropertySelectionType propertySelectionType
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySelectionType PropertySelectionType
The property selection type.

Return Value

IList String
The array of the property set names in the template.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also