GetConductorMaterialIds Method


Conductor Material Get Conductor Material Ids Method

Gets all the Conductor Material ids in the given document, sorted by name.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static IList<ElementId> GetConductorMaterialIds(
	Document document
)

Parameters

document Document
The document.

Return Value

IList ElementId
All the Conductor Material ids in this document.
Exceptions
Exception Condition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also