ConductorMaterial Class


Conductor Material Class

This class represents the definition of Conductor Material data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ConductorMaterial

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class ConductorMaterial : IDisposable

The ConductorMaterial type exposes the following members.

Properties
Name Description
Public property Id The Conductor Material id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The Conductor Material name.
Top
Methods
Name Description
Public method Static member Create Creates a Conductor Material.
Public method Dispose Releases all resources used by the ConductorMaterial
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Static member GetConductorMaterial Gets the Conductor Material data by given Conductor Material id.
Public method Static member GetConductorMaterialIdByName Gets the Conductor Material id by given Conductor Material name.
Public method Static member GetConductorMaterialIds Gets all the Conductor Material ids in the given document, sorted by name.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also