Insulation
|
Gets the Conductor Insulation Material data by given Conductor Insulation Material id.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public static InsulationMaterial GetInsulationMaterial(
Document document,
ElementId insulationMaterialId
)
Parameters
- document Document
- The document.
- insulationMaterialId ElementId
- The Conductor Insulation Material id.
Return Value
InsulationMaterialThe Conductor Insulation Material data.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The id is not a Conductor Insulation Material id. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |