SetTerminationPlaneNormalForBarIdx Method


Rebar Update Curves Data Set Termination Plane Normal For Bar Idx Method

Sets the plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetTerminationPlaneNormalForBarIdx(
	int end,
	int barPositionIndex,
	XYZ terminationPlaneNormal
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
Index of the bar for which it will set the termination plane normal.
terminationPlaneNormal XYZ
The plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException Invalid end. -or- terminationPlaneNormal has zero length.
Remarks
This information is set to the rebar after the API execution is finished successfully. Before setting the value a validation will be done. We consider a termination's plane normal valid if it's perpendicular with the bar direction at end. This method does not take into account the rotation of the bar relative to its default position along the distribution path.
See Also