SetTerminationPlaneNormalForBarIndex Method


Rebar Free Form Accessor Set Termination Plane Normal For Bar Index Method

Sets the plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetTerminationPlaneNormalForBarIndex(
	int end,
	int barPositionIndex,
	XYZ terminationPlaneNormal
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (NumberOfBarPositions-1).
terminationPlaneNormal XYZ
The plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex will stay. The normal should be perpendicular to the bar direction at the specified end of bar.
Exceptions
Exception Condition
ArgumentException Normal terminationPlaneNormal for end end isn't a valid normal for bar with index barPositionIndex
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. -or- terminationPlaneNormal has zero length.
InvalidOperationException This RebarFreeFormAccessor Rebar is constrained.
Remarks

This method does not take into account the rotation of the bar relative to its default position along the distribution path.

See Also