GetConductorMaterial Method


Conductor Material Get Conductor Material Method

Gets the Conductor Material data by given Conductor Material id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static ConductorMaterial GetConductorMaterial(
	Document document,
	ElementId conductorMaterialId
)

Parameters

document Document
The document.
conductorMaterialId ElementId
The Conductor Material id.

Return Value

ConductorMaterial
The Conductor Material data.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The id is not a Conductor Material id.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also