CanBeTerminationPlaneNormal Method


Rebar Free Form Accessor Can Be Termination Plane Normal Method

A vector can be termination (e.g. hook, crank) plane normal if for a bar specified by index, the bar direction is not parallel with the vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanBeTerminationPlaneNormal(
	int barIndex,
	int end,
	XYZ normal
)

Parameters

barIndex Int32
The index of bar for which it will try to see if termination plane normal is applicable.
end Int32
The end of bar. Should be 0 for start, 1 for end.
normal XYZ
The termination's plane normal that will be tested.

Return Value

Boolean
A vector can be termination (e.g. hook, crank) plane normal if for a bar specified by index, the bar direction is not parallel with the vector.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end.
Remarks

This method does not take into account the rotation of the bar relative to its default position along the distribution path.

See Also