EndTreatmentTypeIdAtStart Property


Rebar Shape Terminations Data End Treatment Type Id At Start Property

Identifies the end treatment type at the start of the rebar shape. Setting this property to a valid value, will set the HookAngleAtStart to 0 and HasCrankAtStart to false.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId EndTreatmentTypeIdAtStart { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: endTreatmentTypeIdAtStart doesn't represent an end treatment type.
ArgumentNullException When setting this property: A non-optional argument was null
See Also