GetHookOrientationAngleAtIndex Method


Rebar Free Form Accessor Get Hook Orientation Angle At Index Method

Note: This API is now obsolete.

Gets the termnination's rotation angle that is applied to this Rebar at the bar with index barPositionIndex at the specified end. The rotation angle it's the same for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarFreeFormAccessor.GetTerminationRotationAngleAtIndex instead.")]
public double GetHookOrientationAngleAtIndex(
	int barPositionIndex,
	int end
)

Parameters

barPositionIndex Int32
An index between 0 and (NumberOfBarPositions-1).
end Int32
0 for the start of the bar, 1 for the end of the bar.

Return Value

Double
Returns the termination's rotation angle at the specified end. The rotation angle it's the same for both hook and crank.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1. -or- barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
Remarks

If this Rebar has Workshop Instructions set to Straight will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).

If this Rebar has Workshop Instructions set to Bent there are different cases:

  • All bars are matched exactly with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).
  • All bars are matched in reversed order with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).
  • Some bars are matched in reversed order and the others are matched exactly with a shape. In this case for bars that are matched reversed will return the rotation angle at the opposite end. For the others bars will return the same as Rebar.GetTerminationRotationAngle(int end).

See Also