BendingDetailCustomFieldProperties Class


Bending Detail Custom Field Properties Class

Represents the properties of a Bending Detail Custom Field.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure BendingDetailCustomFieldProperties

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class BendingDetailCustomFieldProperties : ICustomFieldProperties, 
	IDisposable

The BendingDetailCustomFieldProperties type exposes the following members.

Properties
Name Description
Public property AngularDimensionsDisplayOption Identifies the angular dimensions display options.
Public property AngularDimensionsEnabled Identifies if any angular dimensions will be shown or not.
Public property AngularDimensionsForCranksEnabled Identifies if the angular dimensions which has a reference set on a crank will be shown or not.
Public property AngularDimensionsForHooksEnabled Identifies if the angular dimensions which has a reference set on a hook will be shown or not.
Public property AngularDimensionsMeasurementOptions Identifies the measurement option for angular dimensions.
Public property AngularDimensionsOffset Identifies the offset of the angular dimensions.
Public property AngularDimensionTextPosition Identifies the text position with respect to dimension line.
Public property AngularDimensionTypeId Identifies the Id of the angular dimension type which is used to show dimensions.
Public property BendDiameterDimensionsEnabled Identifies if any radial or diameter dimensions will be shown or not.
Public property BendDiameterDimensionsForHooksEnabled Identifies if radial or diameter dimensions will be shown for hook fillets This property has a meaning only if BendDiameterDimensionsEnabled is set to true.
Public property BendDiameterDimensionsForSegmentsEnabled Identifies if radial or diameter dimensions will be shown for the bends between segments. Radial or diameter dimesions for arc segments will be shown by default. This property has a menaning only if BendDiameterDimensionsEnabled is set to true.
Public property BendDiameterDimensionType Identifies what type of bend diameter dimensions will be shown (radial or diameter).
Public property DiameterDimensionTypeId Identifies the Id of the diameter dimension type which is used to show dimensions.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LineStyleId Identifies the line style that is used for drawing Bending Detail curves.
Public property MultipleValuesIndicatorOption Identifies how the Bending Detail will represent the varying rebar dimensions.
Public property OrthogonalAndOverallDimesionsEnabled Identifies if orthogonal and overall dimensions are displayed.
Public property ParametersDisplayOption Identifies how the parameters will be represented.
Public property RadialDimensionTypeId Identifies the Id of the radial dimension type which is used to show dimensions.
Public property RepresentaionOf3DShapes Identifies how the Bending Detail will represent the 3D shapes.
Public property SegmentLengthDimensionsEnabled Identifies if any segment length dimensions will be shown or not.
Public property SegmentLengthDimensionsForHooksEnabled Identifies if segment length dimensions for hooks will be shown or not. If this property is true, the SegmentLengthDimensionsEnabled should also be true to see segment length dimensions for hooks.
Public property SegmentLengthDimensionsOffset Identifies the offset of the segment length dimensions.
Public property SegmentLengthDimensionTextPosition Identifies the text position with respect to dimension line.
Public property SegmentLengthDimensionTypeId Identifies the Id of the linear dimension type which is used to show segments length.
Public property SegmentLengthsDisplayOption Identifies if the segment lengths are represented using dimensions or just as text.
Public property SegmentLengthsForArcsDisplayOption Identifies if the arc segment lengths are represented using dimensions or just as text. Only RebarShapes whose definition is RebarShapeDefinitionByArc are considered that have arc segments.
Public property SegmentsRepresentation Identifies how the bending detail will represent the segments of the bar.
Top
Methods
Name Description
Public method AreEqualTo Identifies if the custom field properties are equal or not.
Public method Dispose Releases all resources used by the BendingDetailCustomFieldProperties
Top
See Also