Gets all the avaliable layer modifier types for the layer key.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
A Revit document to retrieve avaliable layer modifier types from.
- exportLayerKey
- Type: Autodesk.Revit.DB ExportLayerKey
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.
Return Value
The layer modifier types.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |