LookupPostableCommandId Method


Looks up and retrieves the Revit command id with the given id string.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public static RevitCommandId LookupPostableCommandId(
	PostableCommand postableCommand
)
Visual Basic
Public Shared Function LookupPostableCommandId ( _
	postableCommand As PostableCommand _
) As RevitCommandId
Visual C++
public:
static RevitCommandId^ LookupPostableCommandId(
	PostableCommand postableCommand
)

Parameters

postableCommand
Type: Autodesk.Revit.UI PostableCommand
The postable command.

Return Value

The Revit command id. Returning a null reference ( Nothing in Visual Basic) if a command with the given name was not found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when name is a null reference ( Nothing in Visual Basic) .

See Also