Create a symbolic curve in an Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
The geometry curve of the newly created symbolic curve.
- sketchPlane
- Type: Autodesk.Revit.DB SketchPlane
The sketch plane for the symbolic curve.
Return Value
The newly created symbolic curve.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed. |