GetTargetElement Method


Returns the Element object (either Host or Rebar) which provides the constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public Element GetTargetElement()
Visual Basic
Public Function GetTargetElement As Element
Visual C++
public:
Element^ GetTargetElement()

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException RebarConstraint is no longer valid.

See Also