Gets the end points of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentId
- Type: System Int32
The segment id.
- regionId
- Type: System Int32
The region id.
- end1
- Type: Autodesk.Revit.DB UV %
One end point.
- end2
- Type: Autodesk.Revit.DB UV %
The other end point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The segment id is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |