PointLocationOnCurve Constructor


Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public PointLocationOnCurve(
	PointOnCurveMeasurementType measType,
	double measValue,
	PointOnCurveMeasureFrom measFrom
)
Visual Basic
Public Sub New ( _
	measType As PointOnCurveMeasurementType, _
	measValue As Double, _
	measFrom As PointOnCurveMeasureFrom _
)
Visual C++
public:
PointLocationOnCurve(
	PointOnCurveMeasurementType measType, 
	double measValue, 
	PointOnCurveMeasureFrom measFrom
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also