Constructs a filter using multiple types
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- typeList
- Type: System.Collections.Generic IList Type
The list of types to match
- inverted
- Type: System Boolean
True if the filter should match all elements which are not of the given class.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more input types are not subclasses of Element. -or- One or more of the types do not exist in Revit's native object model. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |