ElementCategoryFilter Constructor (BuiltInCategory, Boolean)


Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public ElementCategoryFilter(
	BuiltInCategory category,
	bool inverted
)
Visual Basic
Public Sub New ( _
	category As BuiltInCategory, _
	inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
	BuiltInCategory category, 
	bool inverted
)

Parameters

category
Type: Autodesk.Revit.DB BuiltInCategory
The category to match.
inverted
Type: System Boolean
True if the filter should match all elements which are not of the given category.

See Also