Gets the volume of the material with the given id.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- materialId
-
Type:
Autodesk.Revit.DB
ElementId
The material id returned from GetMaterialIds(Boolean) .
Return Value
The volume of the material for this element. Returns 0.0 if the material is not a part of this element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | materialId is not a valid Element identifier. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |