SetHookPlaneNormalForBarIdx Method


Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public void SetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex,
	XYZ hookNormal
)
Visual Basic
Public Sub SetHookPlaneNormalForBarIdx ( _
	end As Integer, _
	barPositionIndex As Integer, _
	hookNormal As XYZ _
)
Visual C++
public:
void SetHookPlaneNormalForBarIdx(
	int end, 
	int barPositionIndex, 
	XYZ^ hookNormal
)

Parameters

end
Type: System Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex
Type: System Int32
An index between 0 and (NumberOfBarPositions-1).
hookNormal
Type: Autodesk.Revit.DB XYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Normal hookNormal for end end isn't a valid normal for bar with index barPositionIndex
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. -or- hookNormal has zero length.
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException This RebarFreeFormAccessor Rebar is constrained.

See Also