Creates new analytical connections between the equipment connector and the nearest point on the curves.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document where the new elements are created.
- typeId
- Type: Autodesk.Revit.DB ElementId
The type of new analytical connections.
- equipmentOpenConnectors
- Type: System.Collections.Generic IList Connector
The open equipment connectors to be analytically connected.
- curveIdsToConnect
- Type: System.Collections.Generic IList ElementId
The curves which the equipment is connected to.
Return Value
The new analytical connection elements.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Invalid connection type. -or- Not all connectors support the analytical connection. -or- No connector included. -or- Not all elements are valid curve ids. -or- No curve included. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |