Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document that owns the FilterElements displayed and edited in the dialog.
- filterToSelect
- Type: Autodesk.Revit.DB ElementId
The FilterElement to be selected. If InvalidElementId, then the first (if any) available FilterElement will be selected.
Remarks
Show the dialog with the Show() method after setting the desired options.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The supplied ElementId filterToSelect is not of a FilterElement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |