Gets the subelement on given level.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- levelId
- Type: Autodesk.Revit.DB ElementId
The id of the level the railing subelement is placed on.
Return Value
The subelement in given level. a null reference ( Nothing in Visual Basic) will be returned if railing has no subelements on given level.Remarks
The method is valid only for railings hosted by stairs in MultistoryStairs . Input level should be a level of the railing stairs. See getStairsPlacementLevels method of MultistoryStairs .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The railing is not hosted by stairs in MultistoryStairs . |