Creates a new Extrusion Roof.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profile
- Type: Autodesk.Revit.DB CurveArray
The profile of the extrusion roof.
- refPlane
- Type: Autodesk.Revit.DB ReferencePlane
The work plane for the extrusion roof.
- level
- Type: Autodesk.Revit.DB Level
The level of the extrusion roof.
- roofType
- Type: Autodesk.Revit.DB RoofType
Type of the extrusion roof.
- extrusionStart
- Type: System Double
Start the extrusion.
- extrusionEnd
- Type: System Double
End the extrusion.
Remarks
This method will regenerate the document even in manual regeneration mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the work plane does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the level does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the roof type does not exist in the given document. |