Create Method (Document, String)


Creates a new default LoadCombination.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public static LoadCombination Create(
	Document document,
	string name
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	name As String _
) As LoadCombination
Visual C++
public:
static LoadCombination^ Create(
	Document^ document, 
	String^ name
)

Parameters

document
Type: Autodesk.Revit.DB Document
The Document to which new load combination element will be added.
name
Type: System String
The name of the load combination.

Return Value

The newly created load combination element if successful, a null reference ( Nothing in Visual Basic) otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given name is not unique
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also