RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation)


Constructs a new RebarBendData using the bar type, hook types, style and orientation values.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public RebarBendData(
	RebarBarType barType,
	RebarHookType hookType0,
	RebarHookType hookType1,
	RebarStyle style,
	RebarHookOrientation hookOrient0,
	RebarHookOrientation hookOrient1
)
Visual Basic
Public Sub New ( _
	barType As RebarBarType, _
	hookType0 As RebarHookType, _
	hookType1 As RebarHookType, _
	style As RebarStyle, _
	hookOrient0 As RebarHookOrientation, _
	hookOrient1 As RebarHookOrientation _
)
Visual C++
public:
RebarBendData(
	RebarBarType^ barType, 
	RebarHookType^ hookType0, 
	RebarHookType^ hookType1, 
	RebarStyle style, 
	RebarHookOrientation hookOrient0, 
	RebarHookOrientation hookOrient1
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also