Appends an Item to the RebarContainer. Fills its data on base of the Rebar. Will throw exception if given rebar is not shape driven.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebar
- Type: Autodesk.Revit.DB.Structure Rebar
The Rebar.
Return Value
The Rebar Container Item.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The RebarShape of rebar has End Treatments -or- Can't create container from free-form rebar. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |