Checks if given type is valid duct type.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- ductTypeId
- Type: Autodesk.Revit.DB ElementId
ElementId of the duct type to check.
Return Value
True if duct type can used for this duct, false otherwise.Remarks
A type is valid for duct if it can be used to the duct element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |