IsDuctTypeId Method


Checks if given type is valid duct type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool IsDuctTypeId(
	Document document,
	ElementId ductTypeId
)
Visual Basic
Public Shared Function IsDuctTypeId ( _
	document As Document, _
	ductTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsDuctTypeId(
	Document^ document, 
	ElementId^ ductTypeId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
ductTypeId
Type: Autodesk.Revit.DBElementId
ElementId of the duct type to check.

Return Value

True if duct type can used for this duct, false otherwise.

Remarks

A type is valid for duct if it can be used to the duct element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also