IsDuctTypeId Method


Duct Is Duct Type Id Method

Checks if given type is valid duct type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsDuctTypeId(
	Document document,
	ElementId ductTypeId
)

Parameters

document Document
The document.
ductTypeId ElementId
ElementId of the duct type to check.

Return Value

Boolean
True if duct type can used for this duct, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A type is valid for duct if it can be used to the duct element.
See Also