Gets a list of all segments of a given profile shape that define a given size.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- size
- Type: System Double
The size to search for.
- shape
- Type: Autodesk.Revit.DB ConnectorProfileType
The profile shape of segment object.
Return Value
A list of all segments that define a given size.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |